Jump to content
308AR.com Community
  • Visit Aero Precision
  • Visit Brownells
  • Visit EuroOptic
  • Visit Site
  • Visit Beachin Tactical
  • Visit Rainier Arms
  • Visit Ballistic Advantage
  • Visit Palmetto State Armory
  • Visit Cabelas
  • Visit Sportsmans Guide
kayjaygee_13

Issues with Aero Precision build

Recommended Posts

Check that gas block, you may save yourself a hassle and Aero some money. Maybe it’s just the filming conditions but I didn’t see a hint of gas from that carrier. No way will checking it cause any warranty issues.

Curious if you oiled the chamber. It did seem to keep ahold of that casing, could be a tight or rough chamber.

Edited by jtallen83

Share this post


Link to post
Share on other sites

gas is fubared.. take the hg off and snap a pick straight down the barrel. then one directly over the gas block looking down at it..

Edited by sketch

Share this post


Link to post
Share on other sites

if you dont want to, send it back and have them check the gasblock..and port size.

Edited by sketch

Share this post


Link to post
Share on other sites
On 3/30/2019 at 12:52 AM, 98Z5V said:

He never stated his BCG doesn't move at all - he only stated that spent brass isn't getting out of the gun.  First culprit is the BCG length, and that's the quickest thing to solve, by cutting down the poly bumper on the end of it, until that buffer assembly is 5.200" long.   :thumbup:

The extractor setup isn't the issue, as AP told him - those dual o-rings provide some SERIOUS force on the extractor, and I can say it works, well, myself.  The brass isn't getting out of the gun because the BCG is too long - right now, pending internal depth on the rifle receiver extension.  The BCG isn't cycling far enough, and screwing everything up - IF the extension is 9 11/16" internal depth, and screwed in all the way...

Here are some pictures of spent casings. The scratches on the side appear on all of them.

98Z5V, the internal depth of the rifle extension looks to be 9 9/16 in (picture attached).

17 hours ago, jtallen83 said:

Check that gas block, you may save yourself a hassle and Aero some money. Maybe it’s just the filming conditions but I didn’t see a hint of gas from that carrier. No way will checking it cause any warranty issues.

Curious if you oiled the chamber. It did seem to keep ahold of that casing, could be a tight or rough chamber.

I had used a chamber brush with CLP before taking it to the range that day.

15 hours ago, 08sniper said:

Does it have a larger than normal muzzle flash? Gas has to be going some where

I don't think so. My buddy, who is ex-military did not mention anything either.

6 hours ago, Belt Fed said:

That charging handle looks stuck when you try and pull it back.

It does stick a little. Out of the 7 rounds fired, 2 were stuck and required the buttstock to be mortared to extract them.

17 hours ago, 08sniper said:

Might have someone or yourself check head space. 

Aero, in their reply, mentioned that if removing the extractor O-ring didn't solve the issue, I would have to send the upper and BCG back to them so that they could verify the headspace.

Thank you for the help so far!

 

20190331_135315.jpg

20190331_135338.jpg

20190331_135435.jpg

20190331_135520.jpg

20190331_135533.jpg

20190331_135556.jpg

20190331_142108.jpg

Share this post


Link to post
Share on other sites

In one picture of the brass in profile it looks like there may be some rings showing. This could be from reamer marks left in the chamber. I had an Armalite M15T that had this, similar issue just not as drastic, sent it to Armalite, they honed the chamber and never had a malfunction again. I would still lean to checking the gas system for issues even if the rings are present.

12 minutes ago, kayjaygee_13 said:

20190331_135520.jpg

 

Share this post


Link to post
Share on other sites
42 minutes ago, jtallen83 said:

In one picture of the brass in profile it looks like there may be some rings showing. This could be from reamer marks left in the chamber. I had an Armalite M15T that had this, similar issue just not as drastic, sent it to Armalite, they honed the chamber and never had a malfunction again. I would still lean to checking the gas system for issues even if the rings are present.

 

Same here, I had tp polish the chamber on an AR15 one time. was doing the same thing..

Share this post


Link to post
Share on other sites

since the BCG doesn't move at all I wouldn't think it's a head space issue or a rough chamber . To me there is no gas going rearward at all.the extra tor o ring isn't the problem for the bolt not working it's not being given a chance to show it's working. Send it back at least you will have a working rifle but I would bet we will never know the answer to this riddle.

Share this post


Link to post
Share on other sites

I never could tell if the BCG moved either. One could measure the fired case using the Hornady case measuring tool from the shoulder to the base of the cartridge then compare to a brand new case. It should be ,002 to .005 if theey did a good job machining the chamber. Some rifles can be right at .001 but not many. Anyway, if it's in this ball park the head space is most likely good. If brass comes out smaller than it went in, I say the finishing reamer didn't get used at all.

It is possible to have gas pressure but not enough to over come a case thats to big to fit the chamber. All the energy is used up getting it moving but nothing left to go all the way back.

Based on the words he had to mortar the rifle to get the rifle to unlock sounds like the chamber is to small maybe?

Share this post


Link to post
Share on other sites
3 hours ago, HotRod308 said:

 

It is possible to have gas pressure but not enough to over come a case thats to big to fit the chamber. All the energy is used up getting it moving but nothing left to go all the way back.

Based on the words he had to mortar the rifle to get the rifle to unlock sounds like the chamber is to small maybe?

This right here.  That that's a factory upper, so that's aBallistic Advantage barrel.  Something is going on, bad - and it's not that second o-ring on the extractor, OP - don't take that out, it's not going to make a single difference. 

Call a tech rep at Aero, tell them you have videos of the malfunction, and get an email address to send that same vid to. 

Or, you can send me the upper, and I WILL figure it out quick,ly fix it, test fire it on vid, and get it right back to you.

Edited by 98Z5V

Share this post


Link to post
Share on other sites
11 hours ago, kayjaygee_13 said:

 

98Z5V, the internal depth of the rifle extension looks to be 9 9/16 in (picture attached).

 

 

 

20190331_142108.jpg

Internal depth is 1/8" too short, your buffer is too long...  Those two issues together make a weapon that won't cycle. This certainly isn't helping the cycling, or picking up the next round.  You had those issues early on?  Now, it doesn't cycle...

Share this post


Link to post
Share on other sites

Hey guys, just wanted to provide an update. Aero paid for shipping to have the upper and BCG sent back to them a few weeks ago after seeing the video and I found out earlier today that the barrel did not have a gas port. So they swapped out the barrel and I should get the upper back sometime next week. Hopefully, the gun won't have any issues after that. If it does, I'll be posting on here again. 🙂

I also wanted to say thank you to everyone for their responses and suggestions and a special thank you to 98Z5V! I sincerely appreciate the offer to fix the gun. Thank you again!

Share this post


Link to post
Share on other sites
8 hours ago, kayjaygee_13 said:

Hey guys, just wanted to provide an update. Aero paid for shipping to have the upper and BCG sent back to them a few weeks ago after seeing the video and I found out earlier today that the barrel did not have a gas port. So they swapped out the barrel and I should get the upper back sometime next week. Hopefully, the gun won't have any issues after that. If it does, I'll be posting on here again. 🙂

I also wanted to say thank you to everyone for their responses and suggestions and a special thank you to 98Z5V! I sincerely appreciate the offer to fix the gun. Thank you again!

I'da been pretty freaked out, man, taking that thing apart and finding that it didn't HAVE a gas port!!!   :laffs::banana:

I would'a drilled you one.  It would be in the right location, and it would be the right size - but I would'a shiit when I seen that!...   :lmao:

I'm glad that's resolved, and you got a real answer.  You don't see that much from other companies, when you have to send guns in.  You get a bunch of BS from them, instead...  Great news.   :thumbup:

Share this post


Link to post
Share on other sites

At least they own up to the real problem. Musta been a Friday afternoon rifle. Things happen in any manufacturing process. I would think test firing any assembled product would make for a solid check. 

Share this post


Link to post
Share on other sites
1 hour ago, RedRiverII said:

I don't,  or better I have a difficult time understanding no gas port.  Have you received the rifle back yet?  Best of luck.

No way for the gas to go down the tube to push the BCG rearward. 

Share this post


Link to post
Share on other sites

I think Aero's QC has gotten very spotty in the last two years. Their equipment from 3+ years ago seemed to be much more effective. Two years ago I purchased one of their complete M4E1 uppers which wouldn't shoot worth a darn. I contacted them, and to their credit sent me a return shipping label. After examining it, they said the upper was "out of spec" (whatever that means, no further explanation) and sent me a new complete upper which shot somewhat better. I'm a little leery of their products after seeing this latest screw up.

Edited by mineralman55

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...