Jump to content
308AR.com Community
  • Visit Aero Precision
  • Visit Brownells
  • Visit EuroOptic
  • Visit Site
  • Visit Beachin Tactical
  • Visit Rainier Arms
  • Visit Ballistic Advantage
  • Visit Palmetto State Armory
  • Visit Cabelas
  • Visit Sportsmans Guide
andrewtac

gave up on 300wsm, went to 6.5

Recommended Posts

Well, like I said in the other thread, I got irritated and tired of messing with the 300 wsm.  I have a suppressed bolt gun coming in 6.5, and that is what got let me to messing with the AR10 again.  I put a 20" fluted faxon on it, Rainer BCG (with the high pressure bolt), superlative adjustable block.  I also sold the ridiculously large 8X32X56 nightforce and went with a 4x14x44 vortex HST.  The rifle has lost a bit of weight, will be much more manageable in the field now.  I also put in a heavy buffer and a Tubbs flat spring.  I do have a liberty serenity on order, hopefully the gun will run with the can.  Review of what it was, Accuracy Systems 300WSM with Eagle Arms upper and lower; never worked right; almost always FTE.

So I put it all together, got the bolt sopping wet with oil and went to the range with some 143 ELD-Xs.  The very first round ejected, bolt held open; win!  I picked up the brass, and the primer had blown out.  I was pissed.  I had the block adjusted 2 turns past wide open (in the bleed off range).  So I figured I'd tighten it down all the way closed then open it up a couple turns (in the mid closed range, but not in bleed off).  I went about 1.5 turns open.  Ejection again, brass looked better, but short stroke.  I opened up doing a shot at a time until it held open.  All day I had good ejection.  I had two FTF (where the round got damaged by the bolt) during gas block adjustment; was probably a little under gassed.  I ended up in a happy spot where the brass would go to about 3 oclock, maybe 4.  It is a little over gassed.  There is some damage to the case rims.  I don't think I will reload for this rifle, so not concerned about the brass.  But don't want to replace bolt parts.  Once everything breaks in I might try some more adjusting to prevent the case rim damage, but I am ok with it.  Actually thrilled with it, no longer is it a boat anchor.  It is now fun to shoot.  Once I put the can on, I'll need to adjust again.  It will probably only be shot with the can once I get it.    I was very happy,  Out of 40 rounds, two damaged from FTF, and the rest ejected correctly.  Previously with the 300WSM out of 40 I'd probably damage 10 of them and might eject 3-5.  Accuracy seemed decent, but wasn't really trying.  I'll go back and try again in better conditions.  I got a decent zero at 100. 

Share this post


Link to post
Share on other sites

 Did you change the Caliber with the new Faxon BBL. ?  The Bullet sure seems like a 6.5 CM & you did say you are waiting for a 6.5 Bolt gun .

Edited by survivalshop

Share this post


Link to post
Share on other sites

Another good range day.  Box of ammo, all fed and all bolt hold open on empty mags.  I did a little for accuracy.

143 ELDX

1st Target 100 yards, the shots above and below (12,6) were sight in.  The group of 4 was shot holding on the bull.  I think I pulled the flier.

2nd Target was 200 yd, need to try again.

Any idea what would cause the ejector swipe?  Cases are ejecting 3-4 o'clock.  I am one maybe two clicks open on the gas block passed bolt not holding open.  It seems to be gassed correctly, but the ejector swipe makes me think still to much gas.  If I back down the bolt won't hold open.  IMG_20190627_194857-912x2000.thumb.jpg.356a07e2205dff788643fb40d20e68c3.jpg

IMG_20190627_192220-456x1000.thumb.jpg.3cd7c220f8dc48f6ad218a97646accee.jpg

IMG_20190627_192211-456x1000.jpg

Share this post


Link to post
Share on other sites

Another good range day.  Box of ammo, all fed and all bolt hold open on empty mags.  I did a little for accuracy.

143 ELDX

1st Target 100 yards, the shots above and below (12,6) were sight in.  The group of 4 was shot holding on the bull.  I think I pulled the flier.

2nd Target was 200 yd, need to try again.

Any idea what would cause the ejector swipe?  Cases are ejecting 3-4 o'clock.  I am one maybe two clicks open on the gas block passed bolt not holding open.  It seems to be gassed correctly, but the ejector swipe makes me think still to much gas.  If I back down the bolt won't hold open.  IMG_20190627_194857-912x2000.thumb.jpg.356a07e2205dff788643fb40d20e68c3.jpg

IMG_20190627_192220-456x1000.thumb.jpg.3cd7c220f8dc48f6ad218a97646accee.jpg

Share this post


Link to post
Share on other sites

You'll routinely be able to "find" ejector marks on semi-auto AR-type brass. Very rarely is there "nothing" there.  On yours, can you feel that mark, when you run your finger over it?  If no, don't sweat it. If yes, then bevel that ejector a little - it already has a nice bevel around the edge, but it's got that sharp transition... 

The ejectors that leave the worst marks, no matter what, don't even have a chamfer around the edge of them, and they're square-shouldered.  I learned long ago to knock those things down and save my brass, but that's only because I reload. If I didn't reload, it wouldn't even concern me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...