Jump to content
308AR.com Community
  • Visit Aero Precision
  • Visit Brownells
  • Visit EuroOptic
  • Visit Site
  • Visit Beachin Tactical
  • Visit Rainier Arms
  • Visit Ballistic Advantage
  • Visit Palmetto State Armory
  • Visit Cabelas
  • Visit Sportsmans Guide

LR308 forward assist issue


Recommended Posts

I have an Aero Precision M5 upper. The forward assist slides in and out nicely and the spring does its job when testing fitment and articulation of the push rod....until I try to add the threaded roll pin. There is only one way to put the forward assist into the upper and have the pin slide in to where the threads of the pin and upper meet. However, as soon as I get any thread engagement, the forward assist is held in place by the side pressure of the roll pin and can no longer slide in and out without force. I called Aero and they were surprisingly not surprised by this. The tech on the phone said that it was simply an issue of tolerance stacking and that the Aero parts kit that I used was outsourced and not made by them. (good to know actually before for my next purchase) They took my address and quickly sent me out not just a new threaded roll pin, but a new spring and forward assist as well. Well, unfortunately with all new parts and every combination of the old and the new parts tried, the exact issue remains. There is really not a lot to this set up. Pretty simple mechanically. Has anyone ever heard of the actual roll pin hole itself being drilled wrong and being off by a couple thousandths or so, or even crooked? That is really the only other thing I can think of. I know I could possibly grind the tiniest amount off of the flat on my forward assist to "make it function properly" but, just no. Is this a common thing with the M5? I have several AR15s (all Aero uppers on  those as well) and built every one of them myself with no issues. All forwards assists work flawlessly using the exact same methods tried here. I will be contacting Aero Precision again when they open tomorrow, but I was hoping to get lucky and find a functional answer tonight if anyone else has experienced this so that I can complete this build if possible. I know I can run without a forward assist, but after what I just spent on this pile of parts, I want everything working as it should without compromise.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...