Jump to content
308AR.com Community
  • Visit Aero Precision
  • Visit Brownells
  • Visit EuroOptic
  • Visit Site
  • Visit Beachin Tactical
  • Visit Rainier Arms
  • Visit Ballistic Advantage
  • Visit Palmetto State Armory
  • Visit Cabelas
  • Visit Sportsmans Guide
Metalfabguy

Matrix 308 AR trigger problems

Recommended Posts

Brand new matrix 308AR . Took it to the range to zero the scope. First 5 rds cycled perfect, next 5 rds cycled properly but the trigger pull felt a little heavier. Then, light primer strike. Took out bolt, lubed it up, put back together, got 4 light primer strikes in the next 10 rounds thru it before bolt locked up with one chambered. Couldnt get it to fire so I opened it up, reset trigger manually then closed it and fired it, trigger was EXTREMELY hard to pull, got pissed, packed up to deal with it later (now). I looked around and haven't seen many posts about this topic. 

Share this post


Link to post
Share on other sites

If you’ve looked around you have probably seen it’s hard to diagnose on words. We need details of components, pics, your experience level, what have you tried adjusting, etc so it is like we are there looking at your gun. Can’t say my car won’t start what’s wrong and expect any real help. Go to intro section as well and tell us who you are.

Share this post


Link to post
Share on other sites

All components are stock. As I said it is brand new off the shelf from matrix aerospace. I was running pmc 7.62x51 fmj 149 grain ammo. I have been shooting for about 15 years or so, I have plenty of experience with the ar platform in general, I have just never experienced this kind of issue with a brand new gun, the last one I built (50 beowulf) runs perfect and i used numerous different manufacturers' parts to build it, so it just seemed odd that brand new off the shelf was performing the way it did. I was shooting at a bench with a bipod so the gun was not resting on the mag or anything like that, I know it takes some time to break in a new gun for it to cycle smoother, which is why I immediately lubed it when I had the first issue, I was not specifically asking someone to tell me exactly what was wrong with it but more like seeing if anyone else has had this issue with this rifle and if so, what 3nded up being the problem.. 

Share this post


Link to post
Share on other sites

The trigger getting gradually harder to pull tells me that some sort of garbage has worked it’s way between moving parts. Dismantle, clean, inspect for wear or signs of something breaking, reassemble.  

Share this post


Link to post
Share on other sites
On 9/12/2020 at 1:25 PM, shooterrex said:

You probably had something under the trigger. A blown primer is the usual suspect.

This right here is what popped into my head reading your description.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...